[SPT/CWIS] 1.5 upgrade problems

Edward Almasy ealmasy at scout.wisc.edu
Thu Jul 10 15:43:02 CDT 2008


On Jul 8, 2008, at 4:01 PM, Scott Reeser wrote:
> I specify the same locations/web location as the original install. The
> only problem that seems to pop up is the following
> "sh: /var/www/html/wfr.wlearn.com/OLDVERSION: Permission denied
>
> "The following problems were detected during installation:
>    * Unable to write configuration file."

Both of these are probably a result of the permissions being changed  
on the OLDVERSION file and include/SPT--Config.php file so that the  
account you're installing from and the your server account,  
respectively, cannot write to those files.

One solution would be to use the export functions to export all of the  
resource records (and the user accounts, if you want to preserve  
those) from your existing installation, set up a new installation, and  
then import the records (and user accounts) into the new installation.

If you have existing configuration settings or customizations that you  
want to preserve, though, it may be preferable to correct the  
permissions on these two files and run the upgrade again.

Ed


---
    Edward Almasy                             ealmasy at scout.wisc.edu
    Co-Director                                 1210 W Dayton Street
    Internet Scout                                  Madison WI 53706
    Computer Sciences Department                608-262-6606 (voice)
    University of Wisconsin - Madison             608-265-9296 (fax)





More information about the SPT-CWIS-Users mailing list