CWIS 3.0.0 Released

Internet Scout is pleased to announce the release of CWIS version 3.0.0. The new version is now available for download on the Scout site.
As might be expected from the version number, this is a major release of the software, and one we've been working toward for the past two years.  There were two areas of focus for 3.0:  1) refactoring, upgrading, and expanding the underlying infrastructure to reflect the current state-of-the-art in web software and support the new capabilities we plan to implement in CWIS going forward, and  2) adding new functionality and features that have been requested and/or are now expected as part of a state-of-the-art web-based software platform.  While we haven't achieved everything on our wish list for 3.0.0, we do believe the release delivers significant new functionality and will provide both a very adaptable development platform for custom CWIS-based sites, and a very solid launching pad for new technology in CWIS 4.x and beyond.
A few of the highlights:
  • new faceted searching
  • support for custom user information fields
  • support for multiple uploads to Image fields
  • new conditional privilege system for metadata schemas and fields
  • internal support for multiple metadata schemas
  • incremental keyword search (disabled by default)
  • completely revamped user help
  • CleanURLs plugin (provides SEO-friendly clean URLs for resource browsing and full record pages)
  • CalendarEvents plugin (provides configurable full-featured events calendar)
  • Blog plugin (provides blog support)
  • MobileUISwitcher plugin (provides the ability to automatically switch to a particular user interface if a mobile device is detected)
  • SocialMedia plugin added (provides social-media-friendly data in resource full record pages to make them more easily shareable via social media)
  • UserCreator plugin added (provides the ability to create new user accounts on the fly when editing resource records)
  • upgraded UrlChecker plugin able to check more URLs per day with less server impact
  • significantly expanded developer documentation
(Some features were previously available in the 2.9.0 alpha release.)
CWIS 3.0.0 requires PHP 5.2.1 or newer and MySQL 5.0 or newer.  Sites running CWIS 1.4.0 or SPT 1.4.0 or later can upgrade directly to 3.0.0.  Sites running versions prior to 1.4.0 will first need to upgrade to 1.4.0 and then to 3.0.0.
As always, after installing the new version we ask that you use the Register with Scout feature on the Administration menu to let us know you're using the new version of the software.  It really helps us determine what kind of operating environments the software is running in, and where to go next with development.
We look forward to your feedback on this new version of CWIS.  Comments or questions can be posted in the 3.0.0 release thread on the forums.